<!DOCTYPE html>
<html lang="en" dir="ltr"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
<!--[if IE 9]><html class="ie9 ie" lang="en" dir="ltr"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#"><![endif]-->
<!--[if IE 8]><html class="lt-ie9 ie8 ie" lang="en" dir="ltr"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#"><![endif]-->
<!--[if IE 7]><html class="lt-ie9 ie7 ie" lang="en" dir="ltr"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#"><![endif]-->
<head profile="http://www.w3.org/1999/xhtml/vocab">
  <meta charset="utf-8">
  <meta http-equiv="X-UA-Compatible" content="IE=edge">
  <!-- <meta name="viewport" content="width=device&#45;width, initial&#45;scale=1.0"> -->
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://www.gov.nt.ca/sites/default/files/favicon_0.ico" type="image/vnd.microsoft.icon" />
<link rel="shortlink" href="/node/8281" />
<link rel="canonical" href="/newsroom/news/minister-meets-education-leaders" />
<meta name="description" content="YELLOWKNIFE (May 5, 2017) – Last week, Minister of Education, Culture and Employment (ECE) Alfred Moses, met with Divisional Education Council Chairs and Chairs of the Yellowknife District #1, Yellowknife Catholic Schools, Ndilo District Education Authority, Dettah District Education Authority, Commission scolaire francophone Territoires du Nord-Ouest and the Tłı̨chǫ Community Services Agency to discuss education in the Northwest Territories." />
<meta name="dcterms.type" content="News" />
<meta name="dcterms.subject" content="Government" />
<meta name="dcterms.title" content="Minister Meets with Education Leaders" />
<meta name="dcterms.creator" content="charlotte_digness" />
<meta name="dcterms.publisher" content="Government of the Nothwest Territories" />
  <title>Minister Meets with Education Leaders | Government of Northwest Territories</title>
  <style>
@import url("http://www.gov.nt.ca/modules/system/system.base.css?oknlj6");
</style>
<style media="screen">
@import url("http://www.gov.nt.ca/sites/all/libraries/shadowbox/shadowbox.css?oknlj6");
</style>
<style media="print">#sb-container{position:relative;}#sb-overlay{display:none;}#sb-wrapper{position:relative;top:0;left:0;}#sb-loading{display:none;}
</style>
<style>
@import url("http://www.gov.nt.ca/sites/all/modules/date/date_api/date.css?oknlj6");
@import url("http://www.gov.nt.ca/sites/all/modules/date/date_popup/themes/datepicker.1.7.css?oknlj6");
@import url("http://www.gov.nt.ca/modules/field/theme/field.css?oknlj6");
@import url("http://www.gov.nt.ca/sites/all/modules/views/css/views.css?oknlj6");
</style>
<style>
@import url("http://www.gov.nt.ca/sites/all/modules/ctools/css/ctools.css?oknlj6");
@import url("http://www.gov.nt.ca/modules/locale/locale.css?oknlj6");
@import url("http://www.gov.nt.ca/sites/all/modules/flippy/flippy.css?oknlj6");
</style>
<link type="text/css" rel="stylesheet" href="//netdna.bootstrapcdn.com/twitter-bootstrap/2.3.2/css/bootstrap-combined.min.css" media="all" />
<style>
@import url("http://www.gov.nt.ca/sites/all/themes/bootstrap/css/overrides.css?oknlj6");
@import url("http://www.gov.nt.ca/sites/all/themes/gnwt/css/style.css?oknlj6");
</style>
  <!-- HTML5 element support for IE6-8 -->
  <!--[if lt IE 9]>
    <script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
  <![endif]-->
  <script src="http://www.gov.nt.ca/sites/all/modules/jquery_update/replace/jquery/1.7/jquery.min.js?v=1.7.2"></script>
<script src="http://www.gov.nt.ca/misc/jquery.once.js?v=1.2"></script>
<script src="http://www.gov.nt.ca/misc/drupal.js?oknlj6"></script>
<script src="http://www.gov.nt.ca/sites/all/libraries/shadowbox/shadowbox.js?v=3.0.3"></script>
<script src="http://www.gov.nt.ca/sites/all/modules/shadowbox/shadowbox_auto.js?v=3.0.3"></script>
<script src="//netdna.bootstrapcdn.com/twitter-bootstrap/2.3.2/js/bootstrap.min.js"></script>
<script src="http://www.gov.nt.ca/sites/all/modules/google_analytics/googleanalytics.js?oknlj6"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-54680203-1", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");</script>
<script src="http://www.gov.nt.ca/sites/all/themes/gnwt/bootstrap/js/bootstrap-hover-dropdown.min.js?oknlj6"></script>
<script src="http://www.gov.nt.ca/sites/all/themes/gnwt/js/script.js?oknlj6"></script>
<script src="http://www.gov.nt.ca/sites/all/themes/gnwt/js/cssbs.js?oknlj6"></script>
<script>
          Shadowbox.path = "/sites/all/libraries/shadowbox/";
        </script>
<script>jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"gnwt","theme_token":"lN2uM_IWvXVnSaT7jGi0usgHpF6_FqzkcI9IuwMawkg","js":{"sites\/all\/modules\/jquery_update\/replace\/jquery\/1.7\/jquery.min.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/libraries\/shadowbox\/shadowbox.js":1,"sites\/all\/modules\/shadowbox\/shadowbox_auto.js":1,"\/\/netdna.bootstrapcdn.com\/twitter-bootstrap\/2.3.2\/js\/bootstrap.min.js":1,"sites\/all\/modules\/google_analytics\/googleanalytics.js":1,"0":1,"sites\/all\/themes\/gnwt\/bootstrap\/js\/bootstrap-hover-dropdown.min.js":1,"sites\/all\/themes\/gnwt\/js\/script.js":1,"sites\/all\/themes\/gnwt\/js\/cssbs.js":1,"1":1},"css":{"modules\/system\/system.base.css":1,"sites\/all\/libraries\/shadowbox\/shadowbox.css":1,"0":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"modules\/field\/theme\/field.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"modules\/locale\/locale.css":1,"sites\/all\/modules\/flippy\/flippy.css":1,"\/\/netdna.bootstrapcdn.com\/twitter-bootstrap\/2.3.2\/css\/bootstrap-combined.min.css":1,"sites\/all\/themes\/bootstrap\/css\/overrides.css":1,"sites\/all\/themes\/gnwt\/css\/style.css":1}},"shadowbox":{"animate":true,"animateFade":true,"animSequence":"wh","auto_enable_all_images":0,"auto_gallery":0,"autoplayMovies":true,"continuous":false,"counterLimit":10,"counterType":"default","displayCounter":true,"displayNav":true,"enableKeys":true,"fadeDuration":0.35,"handleOversize":"resize","handleUnsupported":"link","initialHeight":160,"initialWidth":320,"language":"en","modal":false,"overlayColor":"#000","overlayOpacity":0.8,"resizeDuration":0.55,"showMovieControls":true,"slideshowDelay":0,"viewportPadding":20,"useSizzle":false},"better_exposed_filters":{"views":{"xml_blocks":{"displays":{"block":{"filters":[]}}},"backgrounder":{"displays":{"block":{"filters":[]}}},"sidebar_blocks":{"displays":{"block":{"filters":[]}}}}},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"}});</script>
</head>
<body class="html not-front not-logged-in one-sidebar sidebar-first page-node page-node- page-node-8281 node-type-news i18n-en">
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    <div class="wrap-top">
  <div id="topbar" class="navbar">
    <div class="container">
      <div class="row-fluid">

        <a class="btn btn-navbar" data-toggle="collapse" data-target=".top-nav">
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </a>


        <div class="nav-collapse collapse top-nav">
          <nav role="navigation">
                          <ul class="menu nav pull-right"><li class="first leaf"><a href="http://www.gov.nt.ca/" title="">www.gov.nt.ca</a></li>
<li class="leaf"><a href="/departments" title="">Departments</a></li>
<li class="leaf"><a href="http://services.exec.gov.nt.ca/" title="Service Directory">Services</a></li>
<li class="last leaf"><a href="/contact-gnwt" title="Contact the GNWT">Contact</a></li>
</ul>                      </nav>
        </div>

          <div class="region region-header">
    <section id="block-block-10" class="block block-block clearfix">

      
  <form class="search" action="http://google.gov.nt.ca/search" method="get">
<div class="text-input">
<input class="form-control" type="text" name="q" placeholder="I'm looking for...">
<input type="hidden" name="output" value="xml_no_dtd">
<input type="hidden" name="client" value="GNWT_MAIN">
<input type="hidden" name="proxystylesheet" value="GNWT_MAIN">
<input type="hidden" name="getfields" value="*">
<input type="hidden" name="lr" value="lang_en”>
<input type="hidden" name="site" value="All_GNWT">
</div>
<button type="submit">Search</button>
</form>  
</section> <!-- /.block -->
<section id="block-locale-language" class="block block-locale clearfix">

      
  <ul class="language-switcher-locale-url"><li class="en first active"><a href="/newsroom/news/minister-meets-education-leaders" class="language-link active" xml:lang="en" title="Minister Meets with Education Leaders">English</a></li>
<li class="fr last"><a href="/fr/newsroom/le-ministre-rencontre-les-leaders-en-%C3%A9ducation" class="language-link" xml:lang="fr" title="Le ministre rencontre les leaders en éducation">Français</a></li>
</ul>  
</section> <!-- /.block -->
  </div>

      </div>
    </div>
  </div>
<header id="navbar" role="banner">  

<div id="logo-sitename">
  <div class="container">
    <div class="row-fluid">

      
      <a class="logo navbar-btn pull-left" href="/" title="Home">
        <img src="/sites/all/themes/gnwt/images/gnwt-logo.png" alt="Home" />
      </a>

              <h1 class="name"><a href="/" title="Home">Government of Northwest Territories</a></h1>
      
      
    </div>
  </div>
</div>

<div class="navigation navbar">
  <div id="main-menu" class="container">
    <div class="row-fluid">

      <a class="btn btn-navbar" data-toggle="collapse" data-target=".primary-nav">
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </a>

      <div class="nav-collapse collapse primary-nav">
        <nav role="navigation">
          
                        <div class="region region-navigation">
    <section id="block-system-main-menu" class="block block-system block-menu clearfix">

      
  <ul class="menu nav"><li class="first leaf"><a href="/" title="Government of the Northwest Territories&#039; homepage">Home</a></li>
<li class="leaf"><a href="/services/residents" title="Services for Residents">Residents</a></li>
<li class="leaf"><a href="/services/business" title="Services for Businesses">Business</a></li>
<li class="leaf"><a href="/services/visitors" title="Services for Visitors">Visitors</a></li>
<li class="last leaf"><a href="/newsroom" title="Newsroom">Newsroom</a></li>
</ul>  
</section> <!-- /.block -->
  </div>
          
        </nav>
      </div>

    </div>
  </div>
</div>


<div id="breadcrumbs">
  <div class="container">
    <div class="row-fluid">
      <span class="govlink"><a href="http://www.gov.nt.ca" title="www.gov.nt.ca">www.gov.nt.ca</a> <span class="divider">/</span> </span>

      <ul class="breadcrumb"><li><a href="/">www.gov.nt.ca</a><span class="divider">/</span></li><li><a href="/newsroom">Newsroom</a></li></ul>
    </div>
  </div>
</div>


</header>





<div id="main">
<div class="main-container container">

  <div class="row-fluid">

        
  </div>

  <div class="row-fluid">

          <aside class="span4" role="complementary">
          <div class="region region-sidebar-first well">
    <section id="block-menu-menu-newsroom-menu" class="block block-menu clearfix">

      
  <ul class="menu nav"><li class="first leaf"><a href="/newsroom/media-contacts" title="Media Contacts">Media Contacts</a></li>
<li class="leaf"><a href="/newsroom/rss-feeds" title="RSS Feeds">RSS Feeds</a></li>
<li class="leaf"><a href="/newsroom/social-media" title="Social Media Directory">Social Media Directory</a></li>
<li class="last leaf"><a href="/newsroom/spotlights" title="Spotlights">Spotlights</a></li>
</ul>  
</section> <!-- /.block -->
  </div>
      </aside>  <!-- /#sidebar-first -->
      

    <section class="span8">  
      <a id="main-content"></a>
                    <h1 class="page-header">Minister Meets with Education Leaders</h1>
                                                        
<div  about="/newsroom/news/minister-meets-education-leaders" typeof="sioc:Item foaf:Document" class="ds-1col node node-news node-promoted view-mode-full clearfix">

  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p><strong>YELLOWKNIFE (May 5, 2017) </strong>– Last week, Minister of Education, Culture and Employment (ECE) Alfred Moses, met with Divisional Education Council Chairs and Chairs of the Yellowknife District #1, Yellowknife Catholic Schools, Ndilo District Education Authority, Dettah District Education Authority, Commission scolaire francophone Territoires du Nord-Ouest and the Tłı̨chǫ Community Services Agency to discuss education in the Northwest Territories.</p>
<p>There was a positive exchange of views and concerns with discussion focusing on collaboration, communication, and planning for future activities.</p>
<p>Minister Moses updated Board Chairs on his work with the Council of Ministers of Education, Canada (CMEC). He advised that, in July, he will assume the role of Vice Chair of CMEC for two years, followed by a two-year appointment as the CMEC chair. The group agreed this will bring opportunities to the Northwest Territories and increase awareness of accomplishments in northern education and advancing the northern agenda on the national stage.</p>
<p>The Minister and Chairs discussed a number of other items including student mental health, proposed changes to the <em>Education Act</em> and implementation of junior kindergarten (JK).</p>
<p>Following a discussion on student and staff mental health there was consensus that, while good work has been undertaken by many Education Authorities, this issue remains a priority. There is recognition that properly resourced programs and services must be implemented and should reflect Indigenous perspectives.  The group agreed this is a complex, multi-disciplinary issue and that other Government of the Northwest Territories departments and partners must be part of any discussion. </p>
<p>Superintendents advised this is also a pressing national issue and that the July 2017 Canadian Association of School System Administrators conference theme of <em>Healthy Schools, Healthy Communities, Healthy Future</em> will have a focus on mental health. Representatives from ECE and Education Authorities will be attending this conference to learn about and take advantage of professional development opportunities.</p>
<p>Minister Moses thanked Board Chairs for their collaboration and contribution to JK implementation, the success of which is truly a joint effort.</p>
<p>Board Chairs also presented on the best practices and challenges they are facing in their regions. The Minister thanked them for their hard work and asked that they reflect his thanks back to their boards.</p>
<p><strong>Quotes</strong></p>
<p>“We had a very productive meeting and talked about a number of important issues.  It was obvious everyone around the table cares deeply about education.  We had excellent discussions and some thoughtful ideas were brought forward.  We are in a period of transformative change which brings about passionate responses.  We are all agreed we want better results for our students and are rolling up our sleeves and continuing to get to work.  That so many people are sharing their thoughts proves how critical this work is to Northerners.  I am confident the future of our school system is in good hands and I am proud to lead such a motivated team of education leaders.”<br /><span>-</span><strong>Alfred Moses</strong><span>, Minister of Education, Culture and Employment</span></p>
<p>“The Board Chairs value the opportunity to come together as education partners and to meet directly with the Minister.  These meetings allow the chairs the opportunity to share successes and concerns related to education in the Northwest Territories.  With a commitment to transparency and an open dialog, both parties will continue to work together to serve the students of the NWT.”<br /><span>-</span><strong>Miles Welsh</strong><span>, Chair, Yellowknife Catholic Schools</span></p>
<p><strong>Media inquiries:</strong><br /><span>Charlotte Digness</span><br /><span>Media and Communications Coordinator</span><br /><span>Government of the Northwest Territories</span><br /><span>Tel: (867) 767-9140 ext. 11092</span><br /><span>E-mail: </span><a href="mailto:charlotte_digness@gov.nt.ca">charlotte_digness@gov.nt.ca</a></p>
</div></div></div><ul class="flippy">
          
    <li class="prev">
              <a href="/newsroom/news/call-applications-2017-ngo-stabilization-fund" title="‹ Previous">‹ Previous</a>          </li>
          
    <li class="next empty">
              Next ›          </li>
  </ul>

</div>

    </section>

    
  </div>
</div>
</div>
</div><!--wrap-top-->
<div id="footer" class="navigation navbar">
  <div class="container">
    <div class="row">

      <a class="btn btn-navbar" data-toggle="collapse" data-target=".secondary-nav">
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </a>

      <div class="nav-collapse collapse secondary-nav">
        <div class="region region-footer">
    <section id="block-menu-menu-footer-menu-default" class="block block-menu clearfix">

      
  <ul class="menu nav"><li class="first leaf"><a href="http://rdirectory.gov.nt.ca/rDirectory.aspx" title="GNWT Employee Phone Directory">Phone Directory</a></li>
<li class="leaf"><a href="/terms" title="Terms of Use">Terms of Use</a></li>
<li class="leaf"><a href="/accessibility" title="Accessibility">Accessibility</a></li>
<li class="leaf"><a href="/contact-gnwt" title="Contact the GNWT">Contact</a></li>
<li class="last leaf"><a href="/information-employees">Information for Employees</a></li>
</ul>  
</section> <!-- /.block -->
  </div>
      </div>
    </div>
  </div>
</div>
  </body>
</html>
